Un PPA pour Glances

Date: 13/03/2012 | Catégories: Open-source,Planet-libre,Reseau,Systeme | Tags: ,,,,

Grâce à Arnaud Hartmann (un grand merci à lui), un PPA est maintenant disponible pour installer la dernière version stable de Glances sur votre système Ubuntu (ou dérivé).

Le PPA en question couvre les versions d'Ubuntu depuis la 9.10 (Karmic) jusqu'à la future 12.04 (Precise Pangolin).

Pour installer Glances sur votre système via ce PPA, il suffit d'effectuer les actions suivantes:

[cc lang="bash"]

sudo add-apt-repository ppa:arnaud-hartmann/glances-stable

sudo apt-get update

sudo apt-get install glances

[/cc]

A la date de la rédaction de ce billet, la dernière version stable disponible est la 1.3.7. Pour les plus téméraires, il est possible, en parallèle de cette installation, de tester la version expérimentale (1.4b) en utilisant le PPA suivant en lieu et place du stable: ppa:arnaud-hartmann/glances-unstable

Petit bonus pour les lecteurs qui sont arrivés jusqu'ici, la lecture d'un billet (en anglais) de présentation de Glances que je trouve assez bien fait.

  • penthium2

    un grand merci a toi surtout pour ce soft ! et comme tu l’as dis sur twitter, jolie article ici : http://www.hecticgeek.com/2012/03/glances-powerful-monitor-ubuntu-linux/

  • Nouveau PPA « unstable » pour la version 1.4b12 : https://launchpad.net/~arnaud-hartmann/+archive/glances-unstable

  • Merci pour le PPA. Un gain de temps appréciable lorsqu’on veut le maintenir à jour sur plusieurs serveurs.

  • LN27

    Un grand merci. Les indicateurs sont pertinents et je m’en sers régulièrement sur un portable à 488 mo de ram équipé lubuntu. Je suis heureuse de voir ce projet avancer. Je vais pouvoir tester les avancées plus régulièrement.

  • À ce propos, je viens de créer un ebuild pour Gentoo.

    La procédure :
    layman -a laurentb
    emerge sys-process/glances

    Je vois que tu as fait des choses très étranges au niveau du packaging (le setup.py ne marche pas très bien, et je n’ai pas vraiment compris l’intérêt d’utiliser les autotools pour du python).

    Du coup j’ai corrigé le setup.py dans mon ebuild pour profiter des outils de Gentoo autour du setup.py… et ignoré le reste 😉 (comme on peut le voir sur http://git.io/VX10SA)

    Je vais tenter de te proposer un truc propre qui utilise uniquement les outils de packaging python. Ça permettra d’être facilement repackagé un peu partout, d’être accessible par pip et easy_install, etc.

    À part ça, merci pour le logiciel, je trouve ça très pratique.

    • Merci Laurent, je suis effectivement preneur !

      La raison de l’utilisation des autotools est plus de la fainéantise qu’autre chose. Ils permettent d’installer facilement les binaires et les mans.

  • Et comme d’habitude, y’en a toujours pour ubuntu. Sous debian, on se brosse.

    Beau boulot sur glances, je l’ai déjà dis, mais que quelqu’un propose un dépôt debian au lieu de toujours proposer des PPA…

    • Je débute en packaging, pour moi c’est la solution la plus simple pour commencer mais pourquoi pas essayer de faire un dépôt Debian plus tard. Je vais déjà voir comment passeront les mises à jours du logiciel.

  • Merci, ce soft va devenir un must have sans aucun doute 🙂

  • J’en salive d’avance jusqu’à ce que :

    root@machine ~ $ apt-get install glances

    Lecture des listes de paquets… Fait
    Construction de l’arbre des dépendances
    Lecture des informations d’état… Fait
    E: Impossible de trouver le paquet glances

    Mes mirroirs sont pourtant bien à jour et le PPA a bien été ajouté… Qu’est ce que j’ai raté ?

    • Sur qu’elle version de Ubuntu est-tu, et quel PPA (stable / unstable) ?

      • Sur la Ubuntu 10.04.4 LTS en 32 bits.
        C’est vrai que j’aurai du préciser…

        • Je viens de voir que les builds « Maverick », « Lucid », « Karmic » sur stable et « Lucid », « Karmic » sur unstable ont des erreurs sur launchpad, je regarde rapidement pour corriger ça !

  • oliver0513

    Bonjour

    Merci nico pour cette appli très utile je m’en sers actuellement sur un serveur syslog + icinga, un petit coup d’oeil de temps a autres suffit pour
    vérifier que tout va bien ou réagir..simple et nickel

  • Tosage

    Bonjour,

    Le PPA ne contient plus glances ???

    xxxxx@xxxxxx:~$ sudo aptitude install glances
    Lecture des listes de paquets… Fait
    Construction de l’arbre des dépendances
    Lecture des informations d’état… Fait
    Lecture de l’information d’état étendu
    Initialisation de l’état des paquets… Fait
    Impossible de trouver un paquet dont le nom ou la description correspond à « glances »
    Impossible de trouver un paquet dont le nom ou la description correspond à « glances »
    Aucun paquet ne va être installé, mis à jour ou enlevé.
    0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
    Il est nécessaire de télécharger 0o d’archives. Après dépaquetage, 0o seront utilisés.
    Lecture des listes de paquets… Fait
    Construction de l’arbre des dépendances
    Lecture des informations d’état… Fait
    Lecture de l’information d’état étendu
    Initialisation de l’état des paquets… Fait

    Merci d’avance 🙂

    • Pour la version stable seul les packets pour « precise », « oneiric » et « natty » sont fonctionnels. Pour la version de dev, en plus des 3 précédents, « maverick » est fonctionnel. Je vais me pencher rapidement sur un correctif pour les versions plus anciennes.

      Cordialement

      • Tosage

        Merci Arnaud, je suis encore sous Lucid pour ma part 🙂 Je passe de LTS en LTS 😉

        • Le problème est corrigé pour la version stable (1.3.7) sur lucid. J’ai trouvé le problème, les correctifs pour les autres versions devrai suivre dès ce weekend.

          Cordialement

        • Tout les packets sont maintenant fonctionnel, n’hésitez pas à signaler d’éventuels problèmes à l’installation et/ou utilisation.

  • Tosage

    Tout est OK sous Lucid, merci Arnaud 🙂