Adsense-deluxe pour WordPress 2.8.1+

Date: 20/07/2009 | Catégories: Blog,Developpement,Open-source | Tags: ,,,

Si comme moi, vous utilisez le plugin Adsense-deluxe pour gérer les espaces publicitaires de votre blog, vous avez eu la désagréable surprise de tomber sur le message suivant suite à une migration de votre blog vers la version 2.8.1 (ou supérieure) de WordPress:

“You do not have sufficient permissions to access this page”

Cela vient d'un problème de développement de certains plugins (dont Adsense-deluxe qui ne semble plus maintenu par son éditeur). Pour résoudre le problème et refaire fonctionner ce trsè bon plugin avec les dernières versions de WordPress, il suffit changer une ligne de code dans le plugin (remplacer l'appel de la fonction admin_head par admin_menu). Pour vous simplifier la tache,  j'ai modifié le plugin pour vous, il ne vous reste plus qu'a télécharger la version compatible du plugin ici (fichier ZIP à dézipper dans le sous répertoire plugin de votre blog WordPress):


Adsense-deluxe for WP 2.8.1+

PS: votre configuration ne sera pas effacée 😉

  • La classe américaine 😉
    Je ne l’utilisais pas, mais je vais peut-être l’utiliser du coup 😉
    Merci bien

  • Merci trop bien je galérai depuis 3 jours avec cette m…
    t’assure mec

  • kimlyse

    en fait ça déconne il affiche
    « vous navez les droits suffisants na nananana » apres avoir validé le code pour l’ajouter « ad adsense block »

  • Merci pour le fichier. Ça fonctionne très bien.