Besoin de bêta testeurs pour Glances 1.6

Date: 17/01/2013 | Catégories: Developpement,Open-source,Planet-libre | Tags: ,,

Glances 1.6 est en plein développement. Une version bêta vient d'être mise à disposition sur le GitHub officiel. J'ai donc besoin de VOUS pour tester, trifouiller, charger cette version avant sa publication. Je prend en charge de mon coté les tests sous Ubuntu et Debian mais je n'ai pas le temps de mener tous les tests sur les autres distributions et OS.

ineedyou

Comment tester ?

Le plus simple pour tester cette version sans casser son installation existante est de suivre la procédure donnée dans cette page du Wiki pour GNU/Linux (sous Windows, il faut au préalable installer quelques logiciels).

Si vous rencontrez un bug, merci de suivre cette procédure pour me le remonter.

Quoi tester ?

Un peu tout... C'est à dire dans un premier temps un lancement de Glances en mode standalone:

En mode standalone avec le module sensor actif (si vous avez lm-sensors sur votre OS):

En chargeant le nouveau fichier de configuration qui permet de changer les limites des alertes (c'est une des grosses nouveauté de cette version):

Note: vous pouvez bien-sur modifier le fichier de configuration (glances.conf) pour l'adapter à vos besoins.

Puis en mode client/serveur en lançant d'abord le serveur:

Puis le client (sur la même machine):

Besoin de qui ?

Une liste non exhaustive de bêta-testeurs dont j'ai besoin et qui utilisent les systèmes suivants:

  • Arch Linux
  • Centos
  • Redhat
  • Gentoo
  • FreeBSD
  • NetBSD
  • OpenBSD
  • Mac OS
  • Windows 7
  • Windows 8
  • n'importe quel OS sous Python 3.x

Merci d'avance à vous !

  • bonobo

    Salut,
    Je viens de tester sous Gentoo, tout marche nickel sauf si j’utilise le pavé numérique ce qui provoque la fermeture de Glances.

    Cdlt, Fred.

  • bonobo

    P.S. :
    Linux gentoo-home 3.2.5-gentoo #11 SMP Mon Feb 13 02:46:18 CET 2012 x86_64 AMD Athlon(tm) II X2 240 Processor AuthenticAMD GNU/Linux

  • Pillar

    Yop,

    Testé sous Arch :

    % uname -a
    Linux woot 3.6.11-1-ARCH #1 SMP PREEMPT Tue Dec 18 08:57:15 CET 2012 x86_64 GNU/Linux

    python-psutil 0.6.1-2

    (pas de lm_sensors)

    Je n’ai pour le moment rencontré aucun bug, le clavier numérique ne provoque pas de fermeture de Glances.

    Pil.

  • chdorb

    Pareil tout va bien sauf le problème de pavé numérique (que je n’avais pas remarqué avant de lire les commentaires)…

    Fedora 18

    Linux silver 3.7.2-201.fc18.x86_64 #1 SMP Fri Jan 11 22:16:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

    python 2.7.3
    psutils 0.6.1
    lm_sensors 3.3.2

    • Merci du retour. J’ai identifié le bug du pavet numérique. Me reste plus qu’à coder un patch 🙂

    • J’ai patché la dernier version HEAD de Glances sur GitHub pour résoudre le pb du pavé numérique. Peux tu me confirmer que cela marche correctement chez toi ?

      • bonobo

        Hello,
        Malheureusement cela ne fait aucune différence.

        • Bizarre, cela fonctionne parfaitement chez moi… Tu as bien la dernière version ?

          • bonobo

            Je vais re-tester de chez moi en rentrant ce soir

  • Existe-il des tests unitaires pour faciliter ça ?

    • Oui comme c’est indiqué dans la documentation:

      ~/tmp/glances/glances/unitest.py

      Mais rien ne vaut un test en réel pour tester l’interface Curses…

      • François

        Super. Je préfère perso commencer par ça, c’est rapide et ciblé 😉 Bien sûr, ça ne dispense pas de tester l’intégration.

  • lolo76

    Hello testé sur Mac OS 10.8

    ça fonctionne impeccable sauf que dés le départ le tri est mauvais (sur le cpu je crois) et l’on ne voit que des process root. J’ai appuyé sur p est là c’est ok

    Pour l’installation j’ai fait
    wget http://pypi.python.org/packages/source/p/pip/pip-1.2.1.tar.gz
    tar xvf pip-1.2.1.tar.gz
    cd pip-1.2.1
    sudo python setup.py install
    cd ..

    sudo pip install psutil
    sudo pip install pysensor

    mkdir ~/tmp
    cd ~/tmp
    git clone https://github.com/nicolargo/glances.git

    python ~/tmp/glances/glances/glances.py

    Mais psutil fait beaucoup de warning à l’install

    lolo

    • Super ! merci pour le retour. Si tu as le temps, peux tu peux compléter l’issue #158 avec un screenshot du problème sur le tri CPU.

      Merci !

  • Je confirme pour ArchLinux.
    J’ai pas vu de bug.

    Testé en standalone et en client/serveur (client Ubuntu, serveur Arch).

    Merci pour Glances

  • Pour info, je viens de mettre en ligne une nouvelle version de la bêta qui devrait corriger, notamment, le problème du pavé numérique.

    Pour mettre à jour:

    cd ~/tmp/glances
    git pull –all

    Merci pour vos retours !

  • Pour moi sous F18 c’est tout bon
    – Pave numérique OK
    – Tri du CPU OK

  • mmx

    Bonsoir nicolas,

    Je suis régulièrement les actualités sur ton blog et je suis très intéressé par les outils que tu développe, je serais partisans pour participer à ce projet. Si tu est toujours en recherche… N’hésite pas a me contacter.

    Bonsoir

    • Saut et merci pour ta proposition. Je suis tjrs à la recherche de personnes motivées pour participer au développement de Glances ou de solutions qui tournent autours.

      Pour les aspects pratiques, tu peux lire le billet suivant:

      http://blog.nicolargo.com/2011/11/contribuer-a-un-projet-heberge-sur-github.html

      La liste des actions à faire sur Glances sont disponibles ici:

      https://github.com/nicolargo/glances/issues?state=open

      Si tu veux prendre en charge une des actions, merci de m’envoyer un petit mail (contact@nicolargo.com) histoire que l’on ne fasse pas deux fois le travail 🙂

      A+

      • seirem (mmx.old)

        Bonsoir,
        Merci pour le process de contribution sur git c’est très bien détailler , j’active ça demain, je te tiendrais au courant des tâches sur lesquelles je contribuerais.

        Bonne soirées,

        Best regards.

        seirem

  • Pingback: Besoin de bêta testeurs pour Glances 1.6 | Linux, FOSS and IT news | Scoop.it()

  • fqded

    Salut,
    L’appli en 1.6 fonctionne très bien sur slackware14 32bits.