Upgrade de WordPress 2.6 vers 2.7

Date: 11/12/2008 | Catégories: Blog,Open-source,Web | Tags: ,,

Voici la procédure que je viens de suivre pour migrer mon blog de la version 2.6 vers la toute fraîche 2.7.

On sauvegarde

On commence bien sûr par sauvegarder l'ensemble du blog (contenue ET base de donnée), on sait jamais...

On télécharge

La dernière version (2.7) se trouve ici. On la télécharge sur son PC puis on décompresse l'archive.

On va donc obtenir un jolie répertoire wordpress.

On prépare l'installation

Une fois connecté sur votre serveur (via FTp, SSH...), il faut supprimer les répertoires wp-includes et wp-admin.

On installe

On télécharge le contenu du répertoire wordpress sur notre serveur. Attention de ne pas écraser le répertoire wp-contents mais de copier par dessus...

On finalise l'installation

Pour cela il faut se rendre à l'URL suivant: http://monblog.com/wp-admin/upgrade.php

Puis mettre à jour vos plugins.

Et voila le travail 😉

Image 1.png
  • Merci pour cet article il vient à point, j’en cherché un de clair 😉

    Par contre, les fichiers à la racine (wp-settings, wp-config, index.php, etc… ) du blog on les écrase ou on copie par dessus ?

  • Merci, mise à jour de mon blog sans soucis grâce à ton article 🙂

  • Un bon mémo qui peut toujours servir 😉

  • Pingback: Wordpress 2.7 - Comment effectuer la migration()

  • Merci pour l’article simple et clair, la mise à jour c’est correctement déroulé (WordPress 2.5.1 -> 2.7). Pour les fichiers à la racine, l’écrasement permet de conserver le wp-config.php déjà paramètré.

  • Mon blog te remercie, j’avais des petits soucis pour l’upgrade, ton article est tombé à point nommé ! 😉

  • Efficace et en français… merci…
    tes étapes sont très claires et tout c’est bien passé…
    j’ai profité de cette update pour passer ma version anglaise en français, le pied !
    je préciserais donc juste que la version française de l’update est ici : http://fr.wordpress.org/

  • C’est concis et claire. Ma migration de la 2.5 en anglais à la 2.7 en français s’est passé sans encombre. J’ai tout de même désactivé tous mes plugins par précaution pour les réactiver une fois la mise à jour faite.

    Séverine

  • Très cool ce tuto

  • Bonsoir,
    je m’y prends fort tard pour commencer la mise à jour de 2.6.2 vers 2.8.4 en passant d’abord par 2.7.1
    Première question : j’ai sauvegardé la base de données (fichier .sql) mais je ne sais pas si j’ai sauvegardé ce que vous appelez le contenu. Comment s’y prendre?
    Deuxième question, avant de passer à la finalisation, comment recopier wp-contents par dessus l’ancien dossier sans l’écraser ?
    Je serais ravi si j’avais l’air idiot de poser des questions trop faciles.
    Merci

  • @Denis Henri: il n’y a pas de question bêtes 🙂
    Pour sauver le contenu, il faut sauvegarder (par exemple par FTP) l’ensemble du répertoire contenant WordPress. Il contient, par exemple, les images et fichiers liés à votre site.

    Pour la recopie du répertoire wp-contents, les clients FTP permettent d’ajouter les nouveaux fichiers sans écraser les anciens (c’est le mode par défaut). Donc pas de soucis à avoir de ce coté là.

    Bonne migration !

  • encouragé par cette réponse, j’ai donc téléchargé le zip de Worspress 7.1, je l’ai décompressé ; j’ai effacé wp-admin et wp-includes par Filezilla sur l’ancienne version ; toujours par Filezilla, j’ai téléchargé le dossier wordpress 2.7.1. A un moment Filezilla m’a demandé si je voulais écraser un fichier wp-contet, j’ai répondu que je voulais tous les reprendre… Je me suis rendu compte qu’il y avait eu un échec de téléchargement mais je ne sais pas lequel et si Filezilla l’a réparé.
    Mais quand j’ai fait : http://henri.denis07.free.fr/wordpress/wp-admin/upgrade.php, j’ai obtenu la fameuse page « no found ».

  • En essayant d’aller sur le blog, je tombe sur :
    Warning: main(/mnt/102/sdb/7/1/henri.denis07/wordpress/wp-includes/compat.php) [function.main]: failed to open stream: No such file or directory in /mnt/102/sdb/7/1/henri.denis07/wordpress/wp-settings.php on line 203

    Fatal error: main() [function.require]: Failed opening required ‘/mnt/102/sdb/7/1/henri.denis07/wordpress/wp-includes/compat.php’ (include_path=’/mnt/102/sdb/7/1/henri.denis07/include:.:/usr/php4/lib/php’) in /mnt/102/sdb/7/1/henri.denis07/wordpress/wp-settings.php on line 203

  • @Denis: la copie ne semble pas complète. Il te manque des fichiers. Je te conseille de refaire la copie FTP en veillant a ce qu’il n’y est pas d’erreur.

  • Pingback: Le mot du jour » Actu du dimanche : upgrade()